Resetting home directory permissions on macOS

Created by Rhonda Stewart on Fri, 10/08/2021 - 15:11
Published URL:
https://www.ibm.com/support/pages/node/6497375
6497375

Troubleshooting


Problem

You attempt to open SPSS Statistics on the macOS. The software opens then closes right away.

Symptom

Other profiles on the same device succeed.  A new local profile also succeeds.

Cause

This behavior can happen when the profile becomes corrupted.

Resolving The Problem

Reset permissions on the failing profile.
Open the Terminal.app and type: diskutil resetUserPermissions / `id -u`
If you get a message saying "permissions reset on user home directory failed (error -69841)", enter: chflags -R nouchg ~
Then, enter the diskutil command again: diskutil resetUserPermissions / `id -u`
(Note: The quotation marks used are "back" quotation marks. To create a "back" quotation mark, press the ` key.
This key is located directly under the Esc key. This key is also used for typing the tilde ( ~ ) character.)

Document Location

Worldwide

[{"Type":"MASTER","Line of Business":{"code":"LOB10","label":"Data and AI"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSLVMB","label":"IBM SPSS Statistics"},"ARM Category":[{"code":"a8m0z000000GmtjAAC","label":"Statistics"}],"ARM Case Number":"","Platform":[{"code":"PF017","label":"Mac OS"}],"Version":"All Versions"}]

Document Information

Modified date:
08 October 2021

UID

ibm16497375