why does the DASH portal 'freezes' up?

Created by Victor Diaz on Wed, 07/03/2019 - 05:32
Published URL:
https://www.ibm.com/support/pages/node/958287
958287

Question & Answer


Question

Why does the DASH portal seems to 'freeze' up, it doesn't respond to input and the users get logged out?
Log entries in '$DASH_HOME/logs/server1/SystemOut.log' show AMQ threads in 'hung' state:
[11/6/18 10:38:28:489 CET] 00000063 ThreadMonitor W   WSVR0605W: Thread "WebContainer : 20" (00003845) has been active for 751029 milliseconds and may be hung.  There is/are 36 thread(s) in total in the server that may be hung.
    at com.ibm.tivoli.rest.amq.AjaxServlet.getAjaxWebClient(AjaxServlet.java:162)
    at com.ibm.tivoli.rest.amq.AjaxServlet.getAjaxWebClient(AjaxServlet.java:37)
    at org.apache.activemq.web.MessageListenerServlet.doPost(MessageListenerServlet.java:114)

Cause

When co-locating DASH and TBSM/Impact on the same server, there can be port 'contention' by both products for the use of the default ActiveMQ port on '16324', this is the messaging framework used to carry dynamic event data between it's data provider and JazzSM, but can result in 'hung' threads after a while.
To avoid this scenario, we must make sure the REST port is modified to avoid this clash; we can achieve this either during product install, altering the default 'REST_NOTIFICATION_PORT', or post-install, by applying the instructions found on TechNote:
https://www-01.ibm.com/support/docview.wss?uid=swg21960311
and modifying entry:
REST_NOTIFICATION_PORT=16324
from file:
<JAZZ_INSTALL_DIR>/profile/properties/portdef.props

Related Information

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSEKCU","label":"Jazz for Service Management"},"Component":"DASH","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Versions","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Historical Number

TS001570396

Document Information

Modified date:
07 September 2020

UID

ibm10958287