COGNOS ANALYTICS - DAYLIGHT SAVINGS TIME CHANGE RESULTS IN AN UNEXPECTED SHIFT IN SCHEDULE START TIMES

Created by Trevor Comeau on Mon, 10/16/2023 - 11:01
Published URL:
https://www.ibm.com/support/pages/node/7052876
7052876

Troubleshooting


Problem

Following a move to, or from, Daylight Saving Time (DST) schedules might be off by one hour. For example, a schedule that shows a run time of 9:00 might run at 8:00, or 10:00.

The issue affects only intraday schedules. These schedules have the "Daily time interval" box checked and specify parameters that enable them to execute multiple times per day.

The issue can be more pronounced following a schedule synchronization. Commonly referred to as “NC Drop”.

Intraday Schedule Example:

image-20231115103739-1

Symptom

Intraday schedule start times shift inconsistently, up or down by one hour, during the year.

Cause

This has been identified as product defect PH54089 DAYLIGHT SAVINGS TIME CHANGE RESULTS IN AN UNEXPECTED SHIFT IN SCHEDULE START TIMES.
This defect began in version 11.0 GA.

Diagnosing The Problem

To diagnose whether any of your schedules are subject to this issue, use these steps.

  • Run the following SQL against the Content Store database. The result lists all intraday schedules.

SELECT a.NAME "report", c.NAME "folder1", e.NAME "folder2", g.NAME "folder3"
FROM CMOBJNAMES a, CMOBJECTS b, CMOBJNAMES c, CMOBJECTS d, CMOBJNAMES e, CMOBJECTS f, CMOBJNAMES g, CMOBJECTS h, CMOBJPROPS2 k
WHERE b.PCMID = a.CMID and a.ISDEFAULT = 1 and c.ISDEFAULT = 1 and e.ISDEFAULT = 1 and g.ISDEFAULT = 1 and d.CMID = b.PCMID and d.PCMID = c.CMID
and d.PCMID = f.CMID and f.PCMID = e.CMID and f.PCMID = h.CMID and  h.PCMID = g.CMID
and b.cmid = k.CMID and k.CMID IN (SELECT a.CMID FROM CMOBJECTS a, CMOBJPROPS2 b WHERE a.CMID = b.CMID and b.TYPE >= 9 and b.TYPE <= 14)

Resolving The Problem

  • The code required to resolve the issue is contained as of versions.

IBM Cognos Analytics 11.1.7 IF1099 (11.1.7-2309211253)

IBM Cognos Analytics 11.2.4 IF1018 (11.2.4-2309220927)

IBM Cognos Analytics 12.0.2 GA

  • For those schedules that don't match their original intent in a fixed product version, edit and resave those schedules to restore the original intent.
  • Following these step, synchronize all schedules using the following technote:    How to use NC Drop Script in Cognos Analytics

Notes:

All schedules going forward will execute at the correct time - that is, whatever start time the Schedule Edit UI shows.

Once the schedules are remediated, any rollback or upgrade of Cognos to an unfixed version would require these steps to be repeated after upgrading the software back to a fixed version.

Document Location

Worldwide

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Document Information

Modified date:
18 January 2024

UID

ibm17052876