Maximo Server is crashing with heap dump being generated

Created by Bogdan Maria on Sun, 08/04/2019 - 07:28
Published URL:
https://www.ibm.com/support/pages/node/964688
964688

Troubleshooting


Problem

Maximo Server is crashing after severe performance issues are observed.

Symptom

java.lang.OutOfMemoryError message can be found in the System.Out log file

Cause

Maximo Activity Dashboard is activated: https://www.ibm.com/developerworks/mydeveloperworks/blogs/a9ba1efe-b731-4317-9724-a181d6155e3a/entry/performance_maximo_activity_dashboard_perfmon?lang=en

Environment

Maximo 7.6

Diagnosing The Problem

By checking the heap dump generated it can be observed that psdi.server.PerformanceStats class will use a large amount of the Java heap.

Resolving The Problem

Disable the Maximo Activity Dashboard. Go To – System Configuration – Platform Configuration – System Properties and set mxe.webclient.activitydashboard  to FALSE

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Component":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.6","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
07 August 2019

UID

ibm10964688