Troubleshooting
Problem
Maximo Server is crashing after severe performance issues are observed.
Symptom
java.lang.OutOfMemoryError message can be found in the System.Out log file
Cause
Maximo Activity Dashboard is activated: https://www.ibm.com/developerworks/mydeveloperworks/blogs/a9ba1efe-b731-4317-9724-a181d6155e3a/entry/performance_maximo_activity_dashboard_perfmon?lang=en
Environment
Maximo 7.6
Diagnosing The Problem
By checking the heap dump generated it can be observed that psdi.server.PerformanceStats class will use a large amount of the Java heap.
Resolving The Problem
Disable the Maximo Activity Dashboard. Go To – System Configuration – Platform Configuration – System Properties and set mxe.webclient.activitydashboard to FALSE
Document Location
Worldwide
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Document Information
Modified date:
07 August 2019
UID
ibm10964688